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Objectives 
 
You will create the geometry for Mill-Lesson-9, and then generate the toolpaths to machine the 
part on a CNC vertical milling machine. This Lesson covers the following topics: 
 
 Create a 3-dimensional drawing by: 
Creating lines. 
Creating arcs. 
Trimming geometry using Divide / Delete. 
Creating a revolved surface. 
 
 Establish Stock Setup settings: 
Stock size using Bounding Box. 
Material for the part. 
Feed calculation. 
 
 Generate a 3-dimensional milling toolpath consisting of: 
Surface High Speed - OptiArea  
Surface High Speed - Hybrid 
 
 Inspect the toolpath using Mastercam’s Verify and Backplot by: 
Launching the Verify function to machine the part on the screen. 
Generating the NC- code. 
 

High Speed Toolpaths - HST 
3D HST Hybrid toolpaths include a new Optimize cut order checkbox which defines the cut 
order Mastercam applies to different cutting passes in the toolpath. When selected, Mastercam 
works in tiers, ordering the toolpath’s cutting passes based on proximity and safety. Mastercam 
machines features by area until it reaches a common Z-level, then repeats the process until it 
reaches the next common ground. The tool stays in a common ground, which reduces 
unnecessary motion and shortens the length of the toolpath. 
 
Hybrid toolpaths now offer additional options for handling open and closed contours. Closed 
contours contain continuous motion without a need for a retract or reversal of direction. You can 
select climb or conventional machining for these contours. Open contours offer One Way or 
Zigzag cutting options. Open contours set to One Way will use the cutting method selected for 
closed contours. 
 
The new Automatic Offset method controls how Mastercam handles the boundaries between 
steep and shallow areas. If the toolpath engages part surfaces that include core and cavity 
properties, Mastercam applies upper to lower offset methods to core features and lower to 
upper offset methods to cavity shapes. 
The 3D HST toolpaths now calculate more efficient high speed motion at your part’s boundaries. 
To improve regeneration speed, they now only recalculate the necessary sections of the 
toolpath instead of processing the entire toolpath when changes are made. 
 
The 3D HST Project toolpath projects either geometry or a toolpath from an earlier operation 
onto surfaces. Previously, the Project toolpath was only available as a surface roughing 
toolpath. In Mastercam the full suite of high speed toolpath parameters are available to refine 
the tool motion.
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 MILL-LESSON-9 DRAWING 
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TOOL LIST 
 0.500 diameter bull end mill with a 0.125 corner radius to rough machine the pocket. 
 0.500 diameter ball end mill to finish machine the pocket. 
 

MILL-LESSON-9 - THE PROCESS 

 

Geometry Creation 
TASK 1:  Setting environment 
TASK 2:  Create geometry  
TASK 3:  Trim the geometry 
TASK 4:  Create the revolved surface 
TASK 5:  Create boundary curves 
TASK 6:  Save the drawing 
 

Toolpath Creation 
TASK 7:  Define the rough stock using stock setup 
TASK 8:  Rough the pocket using Surface High Speed OptiArea 
TASK 9:  Finish the pocket using Surface High Speed Hybrid 
TASK 10:  Verify the toolpath  
TASK 11:  Save the updated Mastercam file 
TASK 12: Post and create the CNC code file 
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TASK 1: 
SETTING THE ENVIRONMENT 
Before starting the geometry creation you should set up the grid, toolbars and machine type as 
outlined in the Setting the environment section at the beginning of this text: 
1. Set up the Grid.  This will help identify the location of the origin. 
2. Load the Workspace – SETTINGS>Load Workspace>3D Toolpaths to machine a 3D part. 
3. Set the machine type to a Haas Vertical Spindle CNC machine. 

 
TASK 2: 
CREATE GEOMETRY - X0 Y0 LOWER LEFT CORNER 
 In this task you will create the geometry that will be used to create the revolved surface. First 

you will create the circles, C1 through C4 and then create the lines 1 through 7. The arc C5 
will be created using Fillet. 

 
 
 Create Circle #1  
1. Select CREATE>Arc>Circle Center point… 
2. The Circle Center Point ribbon bar appears and you are prompted to Enter the center 

point. 

 
 
3. Before moving on, click in the space for radius and enter a value of 0.25. Next click on the 

icon for radius on the ribbon bar as shown below.  This locks in the radius for the circles.  
To unlock click on the icon for diameter.   

 

4. To satisfy this first prompt click on the FastPoint Icon on the Auto Cursor ribbon bar . 
5. In the space input the X (0.25) and Y (0.5) values for the center of the circle and hit enter. 

Note that you can use a variety of formats to enter coordinates here.  This is very helpful 
when cutting and pasting coordinate values from another document.  You do not need to 
input the Z value for this example. 

6. On the ribbon bar click on Apply  to fix the entity. 
 
 Create Circle #2 
7. To satisfy the prompt Enter the center point click on the FastPoint Icon on the Auto Cursor 

ribbon bar. 
8. In the space input the X (0.625) and Y (0.5) values for the center of the circle and then hit 

the enter key.  

9. On the ribbon bar click on Apply  to fix the entity. 
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 Create Circle #3 
10. To satisfy the prompt Enter the center point click on the FastPoint Icon on the Auto Cursor 

ribbon bar. 
11. In the space input the X (3.750-1.858) and Y (0.5+0.25) values for the center of the circle 

and then hit the enter key.  

12. On the ribbon bar click on Apply  to fix the entity. 
 
 Create Circle #4 
13. To satisfy the prompt Enter the center point click on the FastPoint Icon on the Auto Cursor 

ribbon bar. 
14. In the space input the X (3.750-0.25) and Y (0.625) values for the center of the circle and 

then hit the enter key.  

15. Click on the OK icon  to complete this feature.  

16. Now select the Fit to screen icon . 
 
 Create Line #1 
17. Select from the pull down menu: CREATE>Line>Line Endpoint… 
                    
18. On the graphics screen you are prompted: Specify the first endpoint and the Line ribbon 

bar appears. Note that the Tangent function is activated. 

 
 
19. To satisfy the prompt Specify the first endpoint move the cursor over to the center of the 

grid and as you get close to the Origin (X0Y0) a visual cue appears.    This is the cue 
that will allow you to snap to the origin, with this visual cue highlighted pick the origin. 

20. To satisfy the prompt Specify the second endpoint move the cursor over the area of the 
circle shown below.  Ensure there is no visual snap cue being displayed and click on this 
point.  As Tangent is activated on the line ribbon bar the line will snap to the closest 
tangency point on the circle as shown below right: 

    
 

21. On the ribbon bar click on Apply  to fix the entity. 
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 Create Line #2 
22. To satisfy the prompt Specify the first endpoint move the cursor over the area of the circle 

shown below.  Ensure there is no visual cue being displayed and click on this point.  As 
Tangent is activated on the line ribbon bar the line will snap to the closes tangency point on 
the circle. 

 
 
23. To satisfy the prompt Specify the second endpoint move the cursor over the area of the 

circle shown below.  Ensure there is no visual cue being displayed and click on this point.  
As Tangent is activated on the line ribbon bar the line will snap to the closest tangency point 
on the circle as shown below right. 

      
 

24. On the ribbon bar click on Apply  to fix the entity. 
 
 Create Line #3 
25. To satisfy the prompt Specify the first endpoint move the cursor over the area of the circle 

shown below.  Ensure there is no visual cue being displayed and click on this point.  
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26. To satisfy the prompt Specify the second endpoint move the cursor over the area of the 
circle shown below.  Ensure there is no visual cue being displayed and click on this point.  
As Tangent is activated on the line ribbon bar the line will snap to the closest tangency point 
on the circle. 

 
 

27. On the ribbon bar click on Apply  to fix the entity. 
 
 Create Line #4 
28. Click in the space for Length and enter a value of 0.5 and then hit the tab key. In the space 

for Angle and enter a value of -40.0 and hit enter. 

 
 
29. To satisfy the prompt Specify the first endpoint move the cursor over the area of the circle 

shown below.  Ensure there is no visual cue being displayed and click on this point.  

 
 
30. To satisfy the prompt Select a line  pick the lower line as shown below: 

 

31. On the ribbon bar click on Apply  to fix the entity. 
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 Create Line #5 
32. To satisfy the prompt Specify the first endpoint use the AutoCursor ribbon bar Override 

drop down list – located at top of screen on left.  Open the drop down and select 
Quadrant.  Move the cursor over the area of the circle shown below right and click on the 
circle: 

     
 
33. To satisfy the prompt Specify the second endpoint move the cursor over to the left of the 

circle shown below.  Ensure the visual cue for Horizontal/Vertical   is displayed and 
click on this point.   

 

34. On the ribbon bar click on Apply  to fix the entity. 
 
 Create Line #6 
35. Click on the Multi-line button to activate it. 

 
 
36. To satisfy the prompt Specify the first endpoint move the cursor over to the center of the 

grid a visual cue appears.    With this visual cue highlighted pick the origin. 
37. Click in the space for Length and enter a value of 3.75 and then hit the tab key. In the 

space for Angle enter a value of 0 and hit enter. 

 
 
 Create Line #7 
38. To satisfy the prompt Specify the second endpoint move the cursor over to the right of the 

circle shown below.  When the visual cue for Endpoint   is displayed click on this point.   

  

39. Click on the OK icon  to complete this feature.  
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 Create Fillet #5 
40. Select CREATE>Fillet>Fillet Entities… 
41. On the Fillet ribbon bar enter .25 for the radius.  Ensure the Style of radius is set to 

Normal and the trim button is depressed to turn the trim on. 

  
 
42. When prompted to Fillet: Select an entity, select the two lines shown below: 

 
 
43. Click on the OK icon  to complete this feature.  
 

TASK 3: 
TRIM GEOMETRY 
 In this task you will trim the geometry using Divide / Delete.  There are many different ways 

to accomplish this trimming operation, this is just one method.  If you make a mistake using 
Divide / Delete use the Undo button to start over. 

 
 Trim the circles 
1. Select EDIT>Trim/Break>Trim/Break/Extend 
2. The Trim / Extend / Break ribbon bar appears and you are prompted to Select the entity to 

trim/extend. 

 
 

3. Click on the Divide / Delete   icon to activate it as shown above.  Ensure the icon is 
pressed down to signal that it is activated. 

4. The prompt changes to Select the curve to divide / delete.  Move the cursor over the 
various circles and select in order and position as shown below.  The arc is trimmed back to 
the two closest intersections/end points as shown below.  Placing the cursor over the entity 
to divide / delete shows a preview as shown below left. 

        
 
Note: On some of the circles you will need to select them more than once to completely trim 
them. 
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5. Click on the OK icon  to complete this feature.  
The completed geometry is shown below: 
 

 
 

TASK 4:  
CREATE THE REVOLVED SURFACE 
 In this task you will create a revolved surface using the geometry you have just created and 
revolve the geometry 180 degrees about the X axis. 
 

Revolved surfaces are circular in one direction. You will be prompted to chain an entity that the 
revolved surface will use as a profile. You may choose multiple entities to create many revolved 
surfaces at a time. 
You are then prompted to choose a line to use as the axis of rotation and the revolved surface is 
created. 
If you have chosen multiple entities, a surface for each entity will be created, each having a 
different profile and position and all using the same axis of rotation. Click Apply or Enter when 
done. 

 
 Create Revolved Surface  
1. Select from the pull down menu: CREATE>Surface>Revolved… 
2. On the graphics screen you are prompted: Select profile curve(s) 1. In the Chaining dialog 

window select Partial Chain as shown below: 
3. Select line 1 and ensure the arrow is pointing upwards. If not click on the reverse icon. 
4. Then select line 2 as shown below: 
 

 

Cplane 
Chains only entities that are parallel to the current construction plane 
and at the same Z depth as the first entity you chain. 
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5. Click on the OK icon  in the Chaining dialog window.  
6. Change the End angle to 180 as shown below and hit enter: 

 
 

7. Change the graphics view to Isometric . 
8. For the prompt on the screen Select axis of rotation, select the line shown in the diagram 

above in step 4. 

9. Select the Fit to screen icon . 
10. The arrow should be pointing downwards and the newly created surface should look like 

the diagram below:  If the arrow is not pointing downwards or the surface does not look like 
the image below, select the Reverse icon on the Revolved surface ribbon bar. 

 
 

  
 

11. Click on the OK icon  to complete this feature.  The picture above is set to Wireframe 
display.  

 
12. Select the Shaded icon to display the part in shaded mode. 
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13. Select the Wireframe icon  to return to wireframe display. 
14. Delete the axis of rotation as this will not be required anymore.  Select the Delete entities 

icon  and when prompted to Select entities pick the line shown below and then hit 
enter. 

    
 

TASK 5:  
CREATE BOUNDARY CURVES 
 When you machine the Revolved surface you will be prompted to chain an entity that the 

revolved surface will use as a profile, this task will create that profile. 
 
 Change the current color to enable better visibility of the entities 
1. Select Wireframe color from the Status bar at the bottom of the screen. 

 
 
2. In the Colors dialog box select the red color or type in 12. 

 
 

3. Click on the OK icon  to complete this feature. 
 
 Mirror the initial contour geometry 
 
4. Select Xform>Mirror… 
5. You are first prompted to Mirror: select entities to mirror.  First select the All button on the 

General Selection ribbon bar as shown below: 
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6. The Select All dialog box appears on the left of the screen.  Check mark the Entities box 
and then check mark Lines hold the Ctrl key down and then select Arcs. 

 
 

7. Click on the OK icon  to complete this feature. 

8. To move onto the next step you now need to pick the End Selection icon .  
 
9. After selecting End Selection the Mirror window appears. Set the following values as 

shown below: 
 

 

Use new attributes 
Determines the level and color attributes of the transformed entities. 
 
Select this checkbox to display the Level and Color fields where you 
specify these attributes for the new geometry.  
 
Creating the transformed entities on a different level and in a unique 
color can make them easier to identify. 
 
To create transformed entities using the attributes of the original 
entities, deselect this option. 

 

 

10. Click on the OK icon  to complete this feature. 

11. Click on the Clear Colors  at the top right hand corner of the screen.           
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TASK 6:  
SAVE THE DRAWING 
 
1. Select File. 
2. Select Save as. 
3. In the File name box, type Mill-Lesson-9. 
4. Save to an appropriate location. 
5. Select the Save button to save the file and complete this function. 

 
 

Toolpath Creation 
TASK 7: 
DEFINE THE ROUGH STOCK USING STOCK SETUP 
 
1. Fit to screen . 
2. Select the plus in front of Properties to expand the Toolpaths Group Properties.  Alt-O will 

Show/hide Operations Manager pane. 

 
 
3. Select Stock setup in the Toolpaths Manager window. 
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4. Change the parameters to match the Stock Setup screenshot below: 
 Z zero is at the top of the part. 

 
 
5. Select the Tool Settings tab and change the parameters to match the Tool Settings 

screenshot below.  To change the Material type follow the instructions below: 

 

 
 
 
6. To change the Material type to 

Aluminium 6061 pick the Select button 
at the bottom of the Tool Settings 
page. 

 
7. At the Material List dialog box open 

the Source drop down list and select 
Mill – library. 

 
8. From the Default Materials list select 

ALUMINIUM inch -6061 and then 

select .   
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9. Select the OK button  again to complete this Stock Setup function. 
Your part should look similar to the screen shot below.  With X0 Y0 at the middle left side and Z 
zero at the top of the part. 

 

 
TASK 8: 
SURFACE HIGH SPEED OPTI-AREA 
 
 In this task you will use a 0.5 diameter bull end mill with a 0.125 corner radius to rough out 

the pocket using Surface High Speed>OptiArea. 
 

Optimized toolpaths 
The 3D surface high speed OptiCore, OptiArea, and OptiRest toolpaths support cutters capable 
of machining very large depths of cut. It uses an aggressive, fast, intelligent roughing algorithm 
based on Mastercam’s 2D high speed dynamic milling motion. 
 
A single Optimized toolpath can cut material in two directions, on stepdowns (-Z) and step ups 
(+Z). This highly efficient bi-directional cutting strategy removes the maximum amount of 
material with the minimum of stepdowns, significantly reducing cycle times. 

 
1. From the menu bar select TOOLPATHS>Surface High Speed>OptiArea… 
2. When prompted to Enter new NC name ensure Mill-LESSON-9 is entered and then select 

the OK button . 
3. You are first prompted to Select Drive surfaces, select the All button on the General 

Selection ribbon bar as shown below: 

 
 
4. The Select All dialog box appears on the screen. 

5. Click on the OK icon  to complete and exit this feature. 

6. To move onto the next step you now need to pick the End Selection icon .  
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7. Select the Containment boundary button from the Toolpath/surface selection dialog box. 

 

Use this dialog box to select all the geometry needed for a surface 
toolpath.  
 
Each surface toolpath requires drive geometry selected from the 
graphics window or from a CAD file.  
 

 
8. On the screen you will now see the Chaining dialog box with Chain set and in the graphics 

screen a prompt to Chain 2D tool containment boundary #1.  Ensure the C-plane radio 
button is activated. Now select the line as shown below: 

   
     

9. After the boundary has been successfully chained select the OK button . 

10. Select the OK button  to exit the Toolpath/surface selection dialog box. 
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11. On the Toolpath Type, ensure the Roughing radio button and the OptiArea toolpath are 
selected. 

 
 
12. Now click on Tool and in the lower left corner of the Toolpath parameters page select the 

Select library tool… button. Disable Filter active. 
13. Use the slider bar on the right of this dialog box to scroll down and locate a 0.5 diameter 

bull end mill with a 0.125 corner radius.  Select the end mill by picking anywhere along its 
row. 

14. Select the OK button  to complete the selection of this tool. 
15. Make changes to the Tool parameters page as shown below. 
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16. Select the Cut parameters page and make changes to this page as shown below:  Stock 
to leave on walls and floors is set to 0.020. 

 
 
 
Cut Parameters - Optimized Toolpaths 
As stepdowns are calculated, the dynamic roughing motion clears the material in the -Z 
direction, avoiding any islands. 
 
If you activate step up cuts in the toolpath's Cut Parameters, Mastercam calculates additional 
slices in the +Z direction to remove any material left behind between the step downs—for 
example, islands or large scallops on angled walls.  
 
The step up cuts use a 2D high speed dynamic rest motion to clear leftover material. Step up 
cuts are ordered between stepdowns. 
 
 
Optimize cut order 
Defines the cut order Mastercam applies to different cutting passes in the toolpath. 
 
By Depth: Mastercam machines all cut passes z-level by z-level. 
 
Next closest: Mastercam moves to the closest cut from where it finished the previous cut. 
 
By pocket: Mastercam first machines all the stepdowns, moving from pocket to pocket. After all 
stepdowns on a z-level are machined to completion, Mastercam machines the step-ups by next 
closest, in the safest cut order. 
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17. Select the Tool containment page and make changes to this page as shown below. 

 
 

Tool Containment 
Specify the behaviour of the containment boundary. 
 
Compensate to Inside  
Keep the tool inside this boundary. 
 
Compensate to Center  
Keep the tool centerline inside the boundary (allow up to half of the tool to exit the boundary). 
 
Compensate to Outside 
Allow the entire tool to exit the boundary but keep the tool edge in contact with the boundary. 
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18. Select the Transitions page and make changes to this page as shown below. 

 
 

Transitions  
Use this page to configure an entry method for the toolpath. This defines how and where the 
tool enters the part. 
 
Other parameters let you further refine the entry moves, and set entry feeds and speeds. 
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19. Select the Steep / Shallow page and ensure nothing is activated here. 

 
 
20. Select the Linking Parameters page and make changes to this page as shown below. 

 
 

Linking Parameters  
Use this page to create the links between the cutting passes. In general, you can think of 
linking moves as air moves when the tool is not in contact with the part, compared to cutting 
moves which are configured on the toolpath's Cut parameters page. 
 
First, select a retract method.  This determines how the tool will move between the end of one 
pass and the beginning of another. Then, use the Leads fields to control how the tool moves 
onto and off of the part at the start and end of each cutting pass. These moves are applied to 
each pass no matter which cutting pass is selected.  
Finally, select a Fitting option to control how the entry and exit arcs will be fit into each pass. 
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21. Select the Arc Filter / Tolerance page and make changes to this page as shown below. 

 
 

Arc Filter/Tolerance 
Use this page to control toolpath tolerances. Typically, this involves several sets of variables.  
Mastercam uses the values you enter here to convert the toolpath—originally created using G1, 
G2, G3 motions—to a refined set of "smoothed" G1 motions wherever possible, and within the 
tolerances you specify. 
 
Tolerances Distribution 
The Tolerances Distribution fields display the total tolerance and the formula used to derive it. 
Adjust the total tolerance by entering a value in the Total tolerance field or by changing the 
values of the Cut, Line/Arc and/or Smoothing tolerances. 
 
Line/Arc Filtering and Smoothing  
Toolpath filtering lets you replace multiple very small linear moves — within the filter tolerance 
— with single arc moves to simplify the toolpath. Smoothing distributes a toolpath's node points, 
avoiding the clustering and grouping of points that can cause marks and other imperfections. 
 
Use the different checkboxes to enable or restrict arc creation in specific planes. 
 
Enter minimum and maximum arc radius values to control the size of the arcs Mastercam 
creates in the filtered toolpath. 
 
Define the smoothing tolerance by shifting, removing and/or adding node points along your 
toolpath.  

 
22. Turn the Coolant Flood on. 

23. Select the OK button  to complete this toolpath. 
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24. It may take a while for Mastercam to create the toolpath.  Mastercam’s multi-threading 
functionality will calculate the toolpath while you continue to work.  The green spool of 
thread indicates threading is active. 

 
 
25. If threading is not active, you can turn it on by selecting Settings>Configuration... then 

making the selection indicated below on the Toolpaths tab. 

 
  
The screen should look like the image below: 
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TASK 9: 
FINISH THE POCKET USING SURFACE HIGH SPEED HYBRID 
 In this task you will use a 0.5 diameter Ball end mill to finish the pocket. 
 Mastercam’s Hybrid finishing toolpath addresses steep and shallow areas utilizing both 

scallop and constant Z approaches in a single toolpath. 
 The toolpath switches seamlessly between both methods and cuts in a logical optimized 

order. 
 Most of the parameters you define for the toolpath are similar or the same as other surface 

high speed finishing toolpaths. However, the Step group of settings on the Cut Parameters 
page are unique. Use them to control how Mastercam defines steep and shallow areas. 
 

 
1. From the menu bar select TOOLPATHS>Surface High Speed>Hybrid… 
2. You are first prompted to Select Drive surfaces, select the All button on the General 

Selection ribbon bar as shown below: 

 
 
3. The Select All dialog box appears on the screen. 

4. Click on the OK icon  to complete and exit this feature. 

5. To move onto the next step you now need to pick the End Selection icon .  
6. Select the Containment boundary button from the Toolpath/surface selection dialog box. 
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7. On the screen you will now see the Chaining dialog box with Chain set and in the graphics 
screen a prompt to Chain 2D tool containment boundary #1.  Ensure the C-plane radio 
button is activated. Toolpath display has been turned off for clarity ALT + T. Now select the 
line as shown below: 

       
 

8. After the boundary has been successfully chained select the OK button . 

9. Select the OK button  to exit the Toolpath/surface selection dialog box. 
10. On the Toolpath Type, ensure the Finishing radio button and the Hybrid toolpath are 

selected. 
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11. Select the Tool selection page, then Select library tool… button. 
12. Select the Filter button on the right side of the Tool selection dialog box. 
13. Select the None button in the Tool Types section. 
14. Click on the Endmill2 Sphere type icon as shown in the picture (1) below: 
15. Select the drop down arrow in the Tool diameter (2) field and set it to Equal. 
16. Input the tool diameter (3) as 0.5. 

 
 

17. Select the OK button  to exit. 
18. Select the 0.5 ball end mill. 

 
 

19. Select the OK button  to complete the selection of this tool. 
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20. Make changes to the Tool page as shown below: 
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21. Select the Cut Parameters page and make changes to this page as shown below. 

 
 

Cut Parameters 
Use this page to configure the cutting passes for a hybrid toolpath. This is a finishing toolpath 
which generates waterline-style cut passes for steep regions and scallop cut passes for shallow 
regions. Mastercam switches smoothly between both styles to cut in a logical optimized order. 
Z stepdown 
Defines the constant Z distance between adjacent stepdowns. Mastercam uses these 
stepdowns in combination with the Limiting Angle and 3D stepover to calculate cut passes for 
the hybrid toolpath.  
Mastercam first slices the entire model into sections defined by the Z Stepdown distance. It then 
analyzes the drive surface's slope transition between each stepdown along the specified  
Limiting Angle.  
If the drive surface's slope transition within the stepdown distance is less than the applied 
limiting angle, the hybrid toolpath considers it steep and a single 2D waterline cutting pass is 
generated. Otherwise, the stepdown is defined as shallow. Mastercam uses the 3D stepover 
value to create 3D scallop cut passes along the shallow slope. 
3D stepover 
Defines the spacing between 3D scallop-style cutting passes in shallow stepdowns. 
Preserve Z passes 
Select to maintain Z passes in steep areas. Passes in shallow areas are calculated based on 
the Offset method. Deselect to calculate collapse motion across the entire part when a shallow 
region is encountered. 
Offset method 
Select a method for handling the boundaries between steep and shallow areas from the drop-
down. 
Closed offsets: The boundaries are treated as closed chains when calculating the 3D collapse 
motion. 
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22. Select the Transitions page and make changes to this page as shown below. 

 
 

Transition Page - Hybrid 
Use this page to configure the entry moves that the tool will make as it transitions to new Z 
levels. These moves control the transition to a new set of cuts on a different Z level. 
toolpath.  
 
Select Tangential ramp to create a true high speed transition between the cutting passes. 
Mastercam inserts arcs at the beginning and end of the ramp for the smoothest tool motion into 
and out of the move. 
 

 
23. Select the Steep / Shallow page and ensure nothing is activated here. 
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24. Select the Linking Parameters page and make changes to this page as shown below. 

 
 

Linking Parameters  
Use this page to create the links between the cutting passes. In general, you can think of 
linking moves as air moves when the tool is not in contact with the part, compared to cutting 
moves which are configured on the toolpath's Cut parameters page. 
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25. Select the Arc Filter / Tolerance page and make changes to this page as shown below. 

 
 

Arc Filter/Tolerance 
Use this page to control toolpath tolerances. Typically, this involves several sets of variables.  
Mastercam uses the values you enter here to convert the toolpath—originally created using G1, 
G2, G3 motions—to a refined set of "smoothed" G1 motions wherever possible, and within the 
tolerances you specify. 
 
Define the smoothing tolerance by shifting, removing and/or adding node points along your 
toolpath.  

 
26. Turn the Coolant Flood on. 

27. Select the OK button  to complete this toolpath.  
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28. It may take a while for Mastercam to create the toolpath.  Mastercam’s multi-threading 
functionality will calculate the toolpath while you continue to work.  The green spool of 
thread indicates threading is active. 

 
 
The screen should look like the image below with the toolpaths displayed: 
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TASK 10:   
VERIFY THE TOOLPATH 
 
1. Set the graphics view to the Isometric View by using the toolbar icon at the top of the 

screen.  

2. Select the Screen Fit icon found at the top of the screen to fit the part to the screen.  
3. In the Toolpaths Manager pick all the operations to verify by picking the Select All icon 

. 
4. Select the Verify selected operations icon shown below: 

 
 
5. Maximize the Backplot/Verify window if required. 
6. Activate the Follow option in the Toolpath section of the Verify tab. 

 
 
7. Now select the Home Tab. 

 
 

8. Activate the options shown below in the Visibility section of the Home tab. Initial Stock not 
activated. 

 
 
9. Activate the Color Loop. 
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10. At the top of the screen select the View tab, the Isometric icon and then select Fit. 

 
 
11. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 

 
 
12. Now select the Play Simulation button to review the toolpaths. 

 
 
The verified toolpaths are shown below: 

 
 

13. Select the Close button  in the top right hand corner to exit Verify. 
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TASK 11:  
SAVE THE UPDATED MASTERCAM FILE 
 
1. Select the save icon from the toolbar. 

 
TASK 12:  
POST AND CREATE THE CNC CODE FILE 
 
Please Note: 
Users of the Mastercam Home Learning Edition (HLE) will not be able to Post and Create the 
CNC code file. 

 

1. Ensure all the operations are selected by picking the Select All icon  from the 
Toolpaths manager. 

2. Select the Post selected operations icon G1 from the Toolpaths manager. 

 
 
3. In the Post processing window, make the necessary changes as shown below: 

 
 

4. Select the OK button  to continue. 
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5. Ensure the same name as your Mastercam part file name is displayed in the File name 
window as shown below: 

 
 
6. Select the Save button. 
7. The CNC code file opens up in the default editor: 

 
 

8. Select the  in the top right corner to exit the CNC editor. 
 
This completes Mill-Lesson-9. 
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MILL-LESSON-9 EXERCISES 
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