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Objectives 
 
You will create the geometry for Lathe-Lesson-1, and then generate a toolpath to machine the 
part on a CNC lathe. This lesson covers the following topics:  
 
 Create a 2-dimensional drawing by: 
Creating lines. 
Creating fillets. 
 
 Establish Stock and Chuck settings: 
Stock size. 
Chuck Configuration. 
Material for the part. 
Feed calculation. 
 
 Generate a 2-dimensional lathe toolpath consisting of: 
Lathe Face. 
Lathe Rough. 
Lathe Finish. 
Lathe Cutoff. 
 
 Inspect the toolpath using Mastercam’s Verify and Backplot by: 
Launching the Verify function to machine the part on the screen. 
Using Backplot to identify the correctness of the toolpaths. 
Generating the NC- code. 
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LATHE-LESSON-1 DRAWING 
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TOOL LIST 
Two tools will be used to create this part.   
 Tool #1 Face, Rough and Finish the outside diameters 

Holder: Outside Diameter Rough Right Hand - DCGNR-164D. 
Insert: 80 Degree Diamond Insert – CNMG-432. 

 
 Tool #2 Cutoff the part 

Holder: Outside Diameter Cut-off Right Hand. 
Insert: 0.125” Wide. 

 

LATHE - LESSON - 1 - THE PROCESS 

 

Geometry Creation 
TASK 1: Setting the Environment 
TASK 2: Setting the Construction Planes 
TASK 3:  Create the Geometry 
TASK 4: Create the Fillets (Radius) 
TASK 5:  Save the Drawing 

Toolpath Creation 
TASK 6:  Define the Stock and Chuck Parameters  
TASK 7:  Face the Front of the Part 
TASK 8:  Rough the Outside Diameters 
TASK 9:  Finish the Outside Diameters  
TASK 10: Cut off the Part 
TASK 11:  Backplot the Toolpath 
TASK 12:  Verify the Toolpath 
TASK 13:  Save the Updated Mastercam File 
TASK 14:  Post and Create the CNC Code File 
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Geometry Creation 
TASK 1: 
SETTING THE ENVIRONMENT 
 
Before starting the geometry creation you should set up the grid and toolbars as outlined in the 
Setting the Environment section at the beginning of this text: 
1. Set up the Grid.  This will help identify the location of the origin. 
2. Load the Workspace – SETTINGS>Load Workspace>Lathe to machine a part on the 

Lathe. 
3. Set the MACHINE TYPE to the Lathe Default. 
 
TASK 2: 
SETTING THE CONSTRUCTION PLANES: 
 
 Set the Construction Plane to Lathe diameter +D +Z (WCS) 
1. Click on Planes at the bottom of the screen as shown below: 

 
 
2. Click on Lathe diameter>+D +Z (WCS) as shown below: 
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TASK 3: 
CREATE THE GEOMETRY – THE RIGHT HAND FACE IS AT Z0 
 This task explains how to create the geometry of this part. In this lathe part you only need to 

create half of the geometry, the geometry above the center line.  
 Lines 1 through 5 will be created first and then the fillet and chamfer will be created. 

 
 
 Create Line #1 
1. Watch the videos Lesson-1 - Introduction and Lesson-1 - Task 1 to 3.  
2. Select from the pull down menu CREATE>Line>Endpoint… 

 
 
3. The Line ribbon bar appears. 

 
 
4.   Move the cursor over the center of the grid and as you get close to the origin a visual cue 

appears.   With this visual cue highlighted click the left mouse button. 
 
 The following are Mastercam Visual Cues: 

   

Sam
ple 

not fo
r 

Dist
rib

utio
n



Lathe-Lesson-1 

Lathe-Lesson-1-6 

 
5. You are prompted to “Specify the second endpoint”.  Click in the D value space 

(Diameter) (as shown by the arrow below) and enter a value of 1.0. Hit the Enter key and 
enter a value of 0 for the Z, hit the Enter key again. Note the value of Y is set to Zero, this 
does not need to be input. 

 
 

6. Click on Apply . 
7. A vertical line should be visible as shown below: 

 
 

NOTE: If you make a mistake creating lines, click on the Accept icon  and click on the 

Undo icon . Then redo the Line. 
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 Create Line #2. 
 
8. You are next prompted to “Specify the first endpoint”.  Click on the end of the line that 

was just created as shown below and as you get close to the end point a visual cue 

appears.    This is the cue that will allow you to snap to the endpoint of this line.  With 
this visual cue highlighted pick the end point of the line. 

 
 
9. You are next prompted to “Specify the second endpoint”.  On the Line ribbon bar click in 

the D value space and enter 1.0.  Hit the Enter key and enter a value of -1.5 for the Z.  Note 
the value of Y is set to Zero, this does not need to be input.  Hit the Enter key once again to 
complete this line. 

 
 

10. Click on Accept . 
 
 Create Line #3 
11. You are next prompted to “Specify the first endpoint”.  Click on the end of the line that 

was just created as shown below: 

 
 
12. You are next prompted to “Specify the second endpoint”.  On the Line ribbon bar click in 

the D value space (Diameter) and enter a value of 1.45.  Hit the Enter key and enter a value 
of -1.5 for the Z.  Hit the Enter key once again to complete this line. 

 
 

13. Click on Accept . 
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 Create Line #4 
14. You are next prompted to “Specify the first endpoint”.  Click on the end of the line that 

was just created as shown below: 

 
 
15. You are next prompted to “Specify the second endpoint”.  On the Line ribbon bar click in 

the D value space (Diameter) and enter a value of 1.45.  Hit the Enter key and enter a value 
of -2.0 for the Z.  Hit the Enter key once again to complete this line. 

 
 

16. Click on Accept . 
 
17. Fit the image to the screen by clicking on the Fit to Screen icon as shown below: 

 
 
18. Then by clicking on the Un-Zoom .8 icon as shown below: 

 
 

Fit 
Use this function to maximize your view of visible geometry in the graphics window.  
When you use this function, the system positions and sizes the displayed geometry to fill as 
much of the graphics area as possible. 
 
In addition to using the View menu, you can access this function from the right-click menu, from 
the toolbar, by pressing [Alt+F1], or by pressing the Home key on your keyboard. 
 
Unzoom .8:  
This reduces the size of the displayed geometry to 80% of its current size. 
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 Create Line #5 
19. You are next prompted to “Specify the first endpoint”.  Click on the end of the line that 

was just created as shown below: 

 
 
20. You are next prompted to “Specify the second endpoint”.  On the Line ribbon bar click in 

the D value space (Diameter) and enter a value of 0.  Hit the Enter key and enter a value of 
-2.0 for the Z.  Hit the Enter key once again to complete this line. 

 
 

21. Click on the OK icon  to complete this feature. 

22. Select the Screen Fit icon to fit the part to the screen . 
23. Your geometry should look like the figure below: 
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TASK 4: 
CREATE THE FILLETS 

 
 
 Create the .050 fillet radius. 
 
1. Select CREATE>Fillet>Entities…  

 
 
 

Fillet Entities  
Use this ribbon bar to apply fillets to existing entities.  
 
Before selecting the entities to fillet, choose the fillet style (normal, inverse, circle, clearance), 
and enter the desired radius value.  
 
Then choose the first and second entities. Mastercam's auto-preview feature displays a 
temporary fillet at the selected location. 
 
You can also choose to trim to the fillet or to leave the selected lines untrimmed. Trimming is 
the default, so for no trimming, select the No Trim button. 

 
 
2. The Fillet Entities ribbon bar appears and you are prompted to “Fillet: Select an entity”. 
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3. Click in the space for radius and input .050 and then hit the tab key. 

 
 
4. You are now transported over to the Fillet Style field. Click on the drop down arrow to 

review the various fillet radius styles and then ensure Normal is selected before moving on. 

 

 

5. Ensure the Trim option for fillet is activated, the icon is depressed as shown below: 

 
 
6. Click on line 1 and then click on Line 2 as shown below: 

 
 

7. Click on the OK icon  to complete this feature. 
 
8. The completed fillet is shown below: 
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 Create the .125 radius 
 
9. Select CREATE>Fillet>Entities…  

 
 
10. The Fillet Entities ribbon bar appears and you are prompted to “Fillet: Select an entity”. 

 
 
11. Click in the space for radius and input .125 and then hit the tab key. 

 
 
12. You are now transported over to the Fillet Style field.  Ensure Normal is selected before 

moving on. 

 
 
13. Ensure the Trim option for fillet is activated, the icon is depressed as shown below: 
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14. Click on Line 1 and then click on Line 2 as shown below: 
 

 
 

15. Click on the OK icon  to complete this feature. 
 
16. The completed fillet is shown below: 
 

 
 
17. This completes the geometry for this part. 
 

TASK 5: 
SAVE THE DRAWING 
 
1. Select File. 
2. Select Save As… 
3. In the “File name” box, type Lathe-Lesson-1. 
4. Save to an appropriate location. 
5. Select the Save button to save the file and complete this function. 
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Toolpath Creation 
 

TASK 6: 
DEFINING THE STOCK AND CHUCK PARAMETERS 
1. Select the screen Fit icon. 

 
 
2. Select Un Zoom Previous / .5 

 
 
3. Ensure your screen looks like the image below: 

a. The Toolpaths Manager is open, if it is not Select Alt and O on your keyboard to open it. 
b. The properties icon displays Lathe Default. If it is not turn to the section titled Setting 

the Environment at the beginning of this book. 
c. The Lathe - Lesson-1 Geometry is showing.  
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4. Select the plus in front of Properties to expand the Machine Group Properties. 

  
  
5. This is optional - To expand the toolpaths manager window, click on the outside of the 

window with the left mouse button (hold the button down) and drag it to the right. 

 
 
 
6. Select Stock setup in the Toolpaths Manager window. 
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7. Select the Stock Properties button in the Stock Setup page as shown in the screenshot 
below:  

Note: To learn more about Stock Setup refer to the Tips and Techniques section on the 
Mastercam Training Guide – Lathe DVD that accompanies this book. 

 

 
 
8. In the Machine Component Manager-Stock window click on the Geometry button and 

select Cylinder as shown below: 
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9. In the Stock setup activate Use Margins and set the values as shown below.  Note that 
Axis is set to –Z. 

 
 

10. Click on the OK icon  to complete this feature. 
11. Still on the Stock Setup page activate Fit screen to boundaries. 

 
 

Fit screen to boundaries  
Check to determine that the stock, chuck, and tailstock boundaries are included when fitting 
geometry to the graphics window 
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12. Select the Chuck Properties button in the Stock Setup page as shown in the screenshot 
below: 

 
 
13. In the Chuck Jaws setup set the values as shown below: 

 
 

14. Click on the OK icon  to complete this feature. 
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15. Click on the Tool Settings page: 

 
 
16. Make changes as shown below then click on the Select button: 

 
 
  

Sam
ple 

not fo
r 

Dist
rib

utio
n



Lathe-Lesson-1 

Lathe-Lesson-1-20 

17. Select Lathe – library from the drop down Material List dialog box as shown below:  

 
 
18. Select ALUMINIUM inch - 6061 from the Default Materials list.  

 
 

19. Select the OK button .   

20. Select the OK button  again to complete this Stock Setup function. 
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21. Select the screen Fit icon. 

 
 
Notice the stock setup outline as indicated by broken lines as shown below: 
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TASK 7: 
FACE THE FRONT OF THE PART: 
 In this task you will use a facing tool to face the front of the part in one cut. 
 
1. If required select the Fit icon as shown:  

 
 
2. From the menu bar select TOOLPATHS>Face… 

 
 

3. When prompted to “Enter new NC name” select the OK button  to accept LATHE-
LESSON-1 as shown below: 
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 After selecting the OK button you are confronted with Toolpath parameters page.  The first 
task here will be to select Tool #1 an OD Rough- Right – 80 deg. 

 
4. Click on Tool #1 OD ROUGH RIGHT and make changes in the Toolpath parameters page 

as shown below: 

 
 
5. Select the Face parameters page as shown below: 
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6. Make changes as shown below: 

  

7. Select the OK button  to complete this Lathe Face operation. 
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8. Your screen should look like the image below:  

 
 
 Note: the new Toolpath called 1-Lathe Face. This is where all the toolpath information is 

kept. If changes are required to this toolpath just click on the parameter icon 

 and the Screens from steps 4 through 8 will be available. This is handy 
in case a mistake was made in setting the toolpath parameters or in case a modification 
needs to be made. 

9. To experience how this works, click on the Parameters icon . 
10. Click on the Toolpath parameters tab or the Face parameters tab as shown below: 
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 As you can see, all the toolpath settings (parameters) are available in case a change or 

correction is required. 
 

11. Click on the OK button  to return to the main screen. 
 

TASK 8: 
ROUGH THE OUTSIDE DIAMETERS  
 In this task you will use the same tool as used for the previous facing operation Tool #1 an 

OD Rough- Right – 80 deg. 
 
1. From the menu bar select TOOLPATHS>Rough… 

 
 
2. In the Chaining window Chaining mode is set to Partial by default. 
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3. Select Arc 1 as the start of the Partial chain.  
 

After you have selected the arc ensure that the arrows are pointing up and to the left of the part 

If it is not select the reverse button in the Chaining dialog box:   

 
4. Then select Line 2 as the end entity in this chain. 

 
 
5. Select the OK button  to exit the Chaining dialog window. 
6. In the Toolpath parameters page select the same tool used to face the part Tool #1 OD 

ROUGH RIGHT and make sure the settings are the same as shown below: 
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7. Select the Rough parameters page and make changes as shown below: 

 
 
8. Select the Lead In/Out button select the Lead out page and extend the contour by .2 as 

shown below: 

  
 

9. Select the OK button  to exit this function. 

10. Select the OK button  to exit Rough Parameters. 
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TASK 9:  
FINISH THE OUTSIDE DIAMETERS 
 In this task you will finish the outside diameters in one cut using Tool #1 an OD Rough- 

Right – 80 deg. 
 

1. From the menu bar select TOOLPATHS>Finish… 

  
 
2. Select Last in the Chaining dialog box. 

 
 

3. Select the OK button  to complete the selection. 
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4. Select the same tool used to rough the part; Tool #1 OD Rough Right tool from the tool list 
and make changes as shown below if required: 

 
 
5. Select the Finish parameters page and make changes as shown below:  

 

Sam
ple 

not fo
r 

Dist
rib

utio
n



 

 Mastercam Training Guide   

Lathe-Lesson-1-31 

 

Corner Break: Select the check box to automatically create radii or chamfers on all outer 
corners of the toolpath. Click the button to edit the corner break settings. 

 
6. Select the Corner Break button and make changes as shown below if required: 

  
 
7. Select the OK button  to complete this feature. 
8. Select the Lead In/Out button select the Lead out page and extend the contour by .2 as 

shown below: 

  
 

9. Select the OK button  to exit this function. 

10. Select the OK button  to exit Finish parameters. 
 
 
 

Corner Break  
Use this dialog box to automatically 
create radii or chamfers on all outer 
corners of lathe finish toolpaths.  
You can also set the feed rate when the 
tool creates the radii or chamfers. 
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TASK 10: 
CUTOFF THE PART 
 In this task you will cutoff the part using a .125 wide cutoff tool. 
1. From the menu bar select Toolpaths>Cutoff… 

 
 
2. Select the Alt key and the T key on the keyboard to hide the toolpath lines. 
 

Toolpath Lines visible: 
 

 

 Press Alt T to hide toolpath Lines: 
 

 
 

3. Move the cursor over the corner (where Line 1 and Line 2 meet) until the visual cue  
for End point displays and then click on this point as shown below: 
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4. Scroll down if required in the tool window and select the OD Cutoff Right Width .125 tool 
and make changes as shown below in the Toolpath parameters page: 

   
 
5. Select the Cutoff parameters page and make changes if required as shown below: 

  
 

6. Select the OK button  to exit Cutoff parameters. 
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TASK 11: 
BACKPLOT THE TOOLPATH 
 In this task you will use Mastercam’s Backplot function to view the path the tools take to cut 

this part.  
 Backplot will enable you to review the cutting motions and identify any problem areas when 

cutting the part.  
 When the toolpaths are being Backplotted Mastercam displays tool path information on the 

right of the screen.  Information such as the current tool position in X and Z coordinates. 
 For more information on Backplot see the Tips and Techniques section on the 

multimedia DVD supplied with this text.   

1. To pick all the operations to backplot pick the Select All icon  circled below: 

 
 
 Another method to Select all the operations is by clicking on the Toolpath Group-1 in the 

Toolpaths Manager as shown by the arrow above. 
 
 
2. The next step is to select the Backplot selected operations icon shown below: 

 
 
3. Maximize the Backplot/Verify window if required.   
4. Select the Home Tab if required. 

 
 
5. Activate the options shown below in the Visibility section of the Home tab. 

 

Initial Stock 
This displays the stock before machining. 
Click to cycle through three states: 
On 
Translucent 
Off 
 
Tool 
This displays the tool during Backplot or Verification.  Click to 
cycle through three states as mentioned above 
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6. At the top of the screen select the View tab, the Isometric icon and then select Fit. 

 
 
7. Click on the Backplot tab at the top left of the screen 

 
 
8. Activate the Both option in the Toolpath section of the Backplot tab. 

 

Both 
This displays the entire toolpath and the tool as it travels over 
the displayed toolpath. 
  

 
9. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 

 
 
10. Now select the Play Simulation button to review the toolpaths. 

 
 
11. Now hit the rewind button on the controls to move back to the start position. 

12. After reviewing the Backplot of the toolpaths select the Close button  in the top right 
hand corner to exit Backplot. 
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TASK 12:   
VERIFY THE TOOLPATH 
 Mastercam's Verify utility allows you to use solid models to simulate the machining of a part. 

The model created by the verification represents the surface finish, and shows collisions, if 
any exist.  

 This allows you to identify and correct program errors before they reach the shop floor. 
 Backplot and Verify are very similar. The differences between these two functions are that 

Backplot offers basic simulation options.   Whereas Verify offers material removal, collision 
checking and precision control. 

 For more information on Verify see the Tips and Techniques section on the 
multimedia DVD supplied with this text 

 
1. In the Toolpaths Manager pick all the operations to verify by picking the Select All icon 

. 
   
2. Select the Verify selected operations icon shown below: 

 
 
3. Maximize the Backplot/Verify window if required. 
4. Now select the Home Tab if required. 

 
 
5. Activate the options shown below in the Visibility section of the Home tab. Initial Stock not 

activated. 

 
 
6. Activate the Color Loop to change the color of the tools for the verified part. 

 

Color Loop 
Changes the color of the toolpath or cut stock by 
operation or by tool change.   
 
Choose File Options to set the colors. 

 
7. At the top of the screen select the View tab, the Isometric icon and then select Fit. 
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8. In the lower right corner of the screen now set the run Speed to slow by moving the slider 
bar pointer over to the left as shown below. 

 
 
9. Now select the Play Simulation button to review the toolpaths. 

 
 

 
 
10. Select the Close button   in the top right hand corner to exit Verify. 

 
TASK 13: 
SAVE THE UPDATED MASTERCAM FILE 
 

1. Select the save icon from the toolbar . 
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TASK 14:  
POST AND CREATE THE CNC CODE FILE 
 
Please Note: 
Users of the Mastercam Home Learning Edition (HLE) will not be able to Post and Create the 
CNC code file. 

 

1. Ensure all the operations are selected by picking the Select All icon  from the 
Toolpaths manager. 

 
 
2. Select the Post selected operations button from the Toolpaths manager. 
 Please Note: If you cannot see G1 click on the right pane of the Toolpaths manager window 

and expand the window to the right. 

 
 
3. In the Post processing window, make the necessary changes as shown below: 
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About Post Processing 
NC file:  
Select this option to save the NC file. The file name and extension are stored in the machine 
group properties for the selected operation. If you are posting operations from different machine 
groups or Mastercam files, or batch processing, Mastercam will create several files according to 
the settings for each machine group. 
 
Edit:  
When checked, automatically launches the default text editor with the file displayed so that you 
can review or modify it. 
 

 

4. Select the OK button  to continue. 
5. Ensure the same name as your Mastercam part file name is displayed in the NC File name 

field as shown below: 

 
 
6. Select the Save button. 
7. The CNC code file opens up in the default editor. 

 
 

8. Select the  in the top right corner to exit the CNC editor. 
9. This completes LATHE-LESSON -1. 
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LATHE-LESSON-1 EXERCISE 
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