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OBJECTIVES 
For 5-Axis-Lesson-6 you will generate the toolpaths to machine the part on a Haas UMC-750 
universal milling machine. The part will be held in a 5-axis vise. 
 
This Lesson covers the following topics: 
 
 Importing the machine:  
Mastercam can simulate exact replicas of 
machine tools to ensure crash free programs. 
You will import these files. 

 
 Open an existing file containing:  
The solid geometry for the machine vise 
Solid geometry for the part 
Tools for machining 
 
 Generate toolpaths consisting of: 
3+2 3D roughing, Flow 5 Axis, Curve 5 Axis, and 
Multaxis Deburr 
 
 Inspect the toolpath using Mastercam’s 

Verify and Backplot and Machine Sim by 
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TOOL LIST 
 

 
 
 
 

5-AXIS-LESSON-8 - THE PROCESS 
 
TASK 1:  Import Machine files 
TASK 2:  Setup the Machine 
TASK 3:  Open the Mastercam file 
TASK 4:  Rough the part with OptiRest 
TASK 5:  Finish the surface with Flow 5 Axis 
TASK 6:  Finish the end slots with Curve 5 Axis 
TASK 7:  Finish the middle slot with Curve 5 Axis 
TASK 8:  Deburr the part 
TASK 9:  Setup the Verify and Simulate options 
TASK 10:  Verify and Simulate the part 
  



Five-Axis-Lesson-8 
 

Five-Axis-Lesson-8-4 
 

TASK 1:  
IMPORTING THE MACHINE FILES 
 If Machine Importing was done in the previous lessons, Task 1 and 2 of this lesson can be 

skipped. 
 When importing a machine, the following steps may vary slightly depending on the files your 

provided and the format they are provided in. If your reseller has provided instructions for file 
importing, you should follow those instructions instead of these.  

 Watching the videos for this step may be a beneficial first step. 
 
1. We provide a single file download as one of the lesson steps. This file contains all the 

necessary files for the UMC-750 in this lesson. It does not include a post processor that will 
produce gcode. This file is in a zip format. Save the file in a known location. Open that 
location with Windows Explorer. Ensure File Name Extensions is enabled.  

 
 
2. The file can now be unzipped. Right click on the file and choose Extract All… 

 
 
3. By default, the extraction should be set to output into the same location as the file being 

extracted but into its’ own folder. Click Extract. 
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4. Extraction complete… 

 
 
5. Open the extracted folder. The contents included may vary depending on the supplied 

machine and its options. Our download contains a Control Definition, Machine Definition, 
Post, and Machine Simulation files. 

 
 
 The included post will only populate text blocks within toolpaths. It will not create any gcode. 
 The files now need to be transferred to the default locations for their file types.  
6. Open a second instance of Window Explorer by clicking File>Open new window in the 

already open File Explorer. Having a second window open will make coping files easier. 

 
 
7. In the new window, browse to C:\Users\Public\Documents\Shared Mastercam 2020 

 
 
 We will be copying files into the CNC_MACHINES, MachineSimulation/MachSim, and 

mill/Posts folders in this directory. 
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8. Select the mcam-control and mcam-mmd files. Copy and Paste them into the 
CNC_Machines folder. 

 
 
9. Select the CamInstructor_HAAS_UMC-750 folder. Copy and Paste it into the MachSim 

folder inside of the MachineSimulation folder. 

 
 
10. Select the .pst file. Copy and Paste it into the Post folder inside of the mill folder. 

 
 
 This completes the file importing. 
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TASK 2: 
SETUP THE MACHINE 

 
1. Launch Mastercam. 
2. On the Machine tab, from the Mill pull down menu, select Mange List… 

 
 
3. Select the inch version of the UMC-750 and click Add. The machine will then appear in the 

right menu. Click OK to exit. 

 
 
4. The UMC-750 will now appear in the Mill pull down menu. Select it now. 
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 The machine will now appear in the Toolpaths Manager. 

 
 
5. Expand the properties of the machine and select Files. Click the Edit button on this page. 

  
6. The folder locations for the Post and Control should match those used in the previous task. 

 
 
 You are now ready to program with the UMC-750. 
 
 Machine Simulation setup will be done later when there are available cutting paths.  
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TASK 3: 
OPEN THE MASTERCAM FILE 
 This lesson will start by using an existing Mastercam file which has the part and fixtures 

loaded and in location already, tools with holders defined and speeds and feeds stored. 
Future lessons will walk through the placement of the part and the fixtures as well as tool 
holder selection/modification and speed and feed calculations.  

 The machine loaded in this file is the camInstructor definition of the Haas UMC-750. 
Machine Simulation will also use camInstructor definitions. If you do not have this machine, 
the Default Mill can be used and a Trunnion VMC can be used for Machine Simulation. 

 
1. The file can be downloaded as a step in the Online Lesson. Make note of the save location 

and open the file using the File>Open command in Mastercam. 
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 Tool Settings 
 
Feed is set to From Tool so the 
speeds and feeds set in the tools 
parameters will be used. 
 
Use Tools Step, Peck, Coolant is 
enabled and these values will be 
populated into the created 
operations automatically from the 
tools parameters. 
 
Override Defaults is enabled so 
any adjustments made to the 
retract values will carry over to 
subsequent toolpaths.  
 
The Material type is set correctly 
but will have no effect on the 
toolpaths, it is set for reference only 
here. 
 
  
 
 Stock Setup 
 
The stock has been defined as a 
2.2x2.6x1.2 block. This leaves 
stock on all faces except the 
bottom, which is bolted to the 
fixture. 
 
Depending on the stock you cut, 
adjust the block to accurately 
reflect its dimensions. 
 
The stock block used on the 
machine should have the bottom 
face machined as well as the holes 
already drilled into it.  
 
Z0 for the stock setup is at the 
bottom of the block, which is at the 
top of the fixture. 
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 Levels 
 
Level 1 contains the solid model for 
this project. 
 
Level 5 contains a surface which will 
be used in a toolpath. This surface is 
used to bridge the gaps left by the 
slots. 
 
Level 6 contains geometry which will 
be used for a toolpath. 
 
Level 20 contains solid models that 
can be used for 3D printing.  
 
Level 100 contains all the solids used 
to represent the fixtures.  
 

 

 
 Solids 
 
There are several solids in the file. 
The solids used to represent the vise 
and fixture have been grouped 
together as have the 3D printing 
models. The part model remains 
ungrouped.  
 
Groups can be used when many 
solids are used to represent an 
assembly. The Group can be 
collapsed to de-clutter the Solids 
Manager. 
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TASK 4: 
ROUGH THE PART 
 The part will be roughed out with a 3D OptiRough toolpath. To make the toolpath stock 

aware, a Stock Model must first be made then the OptiRough toolpath can be used as a 
Rest milling operation. 

 
1. Select the Stock Model on the Toolpaths tab.  

 
 

2. Give the Stock Model a name, set the Initial Stock Shape to Rectangle and then click the 
Stock Setup button to populate the origin and size of the rectangle from the values used in 
the Machines Stock Setup page. Click Ok. 

 
 
3. Turn the stock model on/off by using Alt - T or by clicking on the Toolpath Toggle display 

icon. 
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4. From the 3D toolpath gallery, select OptiRough. 

 
 
5. On the Model Geometry page set the Machining Geometry Wall and Floor stock to 0.01 

 
 
6. Use the selection button at the bottom of the Machining geometry section to select the entire 

solid part. You can triple left click on any face of the part. Click End Selection. 

  
 
7.  Toolpath Control page. 

 
Strategy set to From Outside. 
 
Compensate set to Outside with the 
Offset Distance set to 0.5 and Include 
Tool Radius checked. This will allow 
the toolpath to look outside the 
Boundary chain for material to cut.  
If Stock is not used with this operation, 
care must be taken in setting of the 
Offset Distance.  
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8. On the Tool page, select the 1/4 Flat Endmill and enable RCTF. 

   
 
9. Stock page. Check the Rest Material box. Set the stock to One Other Operation and ensure 

the created stock model is selected.  

   
 
 Enabling the Stock will limit where the toolpath will cut. The Toolpath Control settings are 

allowing the operation to start cutting outside of the part boundary but the Stock settings are 
reducing the created toolpaths to locations where there is stock to cut.  

 
10. In the Cut Parameters page adjust the Stepover, Stepdown and Stepup as shown. 
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11. No settings are needed on the Transitions page. This toolpath will not be entering any 
pockets so there is no need to define this motion. 

 The Steep/Shallow page will be used to limit the depth of the toolpath. The path needs to cut 
slightly below the bottom of the part. 

12. On the Steep/Shallow page enable Maximum depth and set this value to -0.05. 

 
 
 The Steep/Shallow setting will be re-visited later. 
13. Linking Parameters. Clearance Plane set to 8.0, Part Clearance set to 0.25. From the retract 

style pulldown select Minimum Vertical Retract, enable Output Feed Move and set to 400 
inches per minute. 

 
 
 The above settings will allow the toolpath to rapid around the part with 0.25 inches of 

clearance. The Output Feed move allows for straight line ‘rapids’ to be performed. Typically, 
machines will dogleg rapid which may lead to unsimulated crashes on the machine.  

  



Five-Axis-Lesson-8 
 

Five-Axis-Lesson-8-16 
 

14. Arc Filter/Tolerance settings as shown. Green check to complete the toolpath. 

 
 
15. If you are prompted about a containment boundary, click Do Not Show and then click Ok. 

The message is stating that since a boundary was not selected, Mastercam will create it’s 
own based off the selected machining data. 

  
 
 The resulting toolpath, fixture hidden for clarity. Backplot the toolpath, notice the estimated 

cycle time. 6m44s. When verified, you may notice a depth cut at 0.0108 and the final depth 
cut at 0.0. The toolpath specified a depth of -0.05, which has not happened. 
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 This is a stock aware toolpath so motion will only be generated where there is stock to cut. 
In order to cut below Z0, the toolpath needs to see stock there to cut. Next, we will adjust 
the stock model to have stock in this area.  

 The depth cuts at 0.0108 and 0.0 are not efficient. Cutting a slightly larger stepdown will 
eliminate this extra depth cut. 

 Time can also be saved by moving faster during non-cutting portions of the toopath. This is 
controlled with the Back Feedrate setting. 

 
16. Click on the Toolpaths Parameters folder to access the toolpaths settings. On the Cut 

Parameters page increase the Stepdown to 0.55 and increase the Back feedrate to 300. 
Click Ok. 

 
 
17. Click the Parameters folder for the Stock model. Adjust the Stock Thickness to 1.3. This 

will add an additional 0.1 of stock below the part. Click Ok. 
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18. Both the Stock Model and Toolpath are dirty. Regenerate both.  
 The adjusted toolpath. Backplot and make note of the new cycle time. 5m20s. The toolpath 

now cuts down to -0.05 as well. 
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TASK 5: 
FINISH THE SURFACE WITH FLOW 5 AXIS 
 The outer surface will be finished with Flow 5 Axis. The solid model could be used for this 

toolpath, but the toolpaths would end at the exact edge of the slots shown below. Extending 
the toolpath over these edges is ideal. One solution is to create surfaces to fill these voids 
and add them to the solid faces for toolpath geometry selection. Alternatively, surfaces can 
be made to represent all the faces to machine. These surfaces can be found on level 5.  

 
 
 These surfaces also extend slightly past the bottom of the part. Check the Tips and 

Techniques section for steps to create this surface. 
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1. Hide Level 1, show Level 5. This level contains the surface for the Flow toolpath. 

 
 
2. Select the Flow Toolpath from the Multiaxis toolpath gallery. 

 
 
3. Select the 3/8 Ball Endmill. Speeds and Feeds should be set automatically. 

 
 
4. On the Cut Pattern page, click the Surface selection button. 
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5. Select all the surfaces (7). Click End Selection. 

 
 
6. Next, the Flowline Data menu will appear. Click the Cut Direction button so the cut matches 

that shown below. Step Direction and Start can be of your choosing. If you do not see the 
preview on the outside of the part, click the Offset button to have the toolpath switch sides of 
the surface. 

 
 
7. Click Ok. 
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8. The remaining settings on the Cut Pattern page will be left at the default setting. If you want 

an improved surface finish, reduce the value for Distance under Step Across..  

 
 
9. The Tool Axis control will be set to Pattern Surface with an Output format of 5 Axis. 

 
 
Output format 
Select 4-axis or 5-axis from the drop-down list. 
 
4-axis: Allows one plane of rotation selected under Rotary axis.  
5-axis: Allows tool axis rotation in any plane. 
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Tool axis control 
Use the drop-down list to select the tool axis control method. Click Select to return to the 
graphics window to select appropriate entities. The number of entities is displayed to the right of 
the Select button.  
 
Lines: Aligns the tool axis along the selected lines. The tool axis will be interpolated for areas 
between the selected lines. Select the lines in such a way that the chaining arrow is pointing 
towards the tool spindle.  
 
Pattern surface: Keeps the tool axis normal to a selected surface. Pattern surface is the only 
option available for 3-axis output. For 3-axis output, Mastercam projects the curves onto the tool 
axis surfaces. The projected curves become the tool contact positions.  
Plane: Keeps the tool axis normal to a selected plane.  
 
From point: Limits the tool axis to originate from a selected point.  
 
To point: Limits the tool axis to terminate to a selected point.  
 
Chain: Aligns the tool axis along a line, arc, spline, or chained geometry.  
 
Boundary: Aligns the tool axis within or on a closed boundary. If the cut pattern surface normal 
is within the boundary, the tool axis stays aligned with the cut pattern surface normal. 
 
 
10. On the Linking page, set the Clearance to 8.0 and enable Only at the Start and End. 
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11. To reduce the toolpaths size, Filtering will be enabled. 

 
 
12. Click Ok to complete the operation. 
13. Backplot the toolpath. Notice, particularly about half-way through the toolpath when 

machining the mid-section, the tool does not disengage from the cut. 

 
 
 Next, confirm this same motion in Simulation which uses the machines limits to determine 

toolpath motion. 
14. Check that the correct machine is selected. 
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15. Both toolpaths will need to be selected, then launch Simulation from the Machine tab. 

 
 
16. The first operation can be skipped over by clicking the Next Operation button. 

 
 
 Once the toolpath gets to the middle section of this part, you will see a retract, then the table 

(C axis) will rotate 180 degrees and then tool will re-engage the cut. This will repeat until the 
mid-section is complete. You may need to single step through the toolpath to see the 
retracting happen. 

 This is happening due to the machine limits in the B axis. The Haas UMC-750 is limited to a 
B axis rotation of +110 and -35. To cut this feature in one complete motion a minimum of 
+90 and -90 would be needed. Alternatively, we can try to limit the toolpath to stay inside of 
the machine’s limits. 

 
17.  Close the Simulation 

 

18.  Open the Flow 5 Axis 
toolpath by clicking on the 
Parameters folder 

19.  Expand the Tool Axis 
Control to show the Limits 
page. 
 
Enable Z Axis limits and set 
the Maximum to 35 degrees. 
 
In the Limit actions, set this to 
MODIFY the motion that 
exceeds. This will try and 
keep the portion of toolpath 
that exceeds 35 degrees but 
keep the B rotation at 35. 
DELETE would remove any 
part of the toolpath that needs 
to rotate beyond 35. 

 
20. Click Ok, and the Regenerate the dirty operation. 
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 The modified toolpath. 

 
 
 Running both toolpaths through Simulate will show no retracts happening in the mid-section 

of the part this time. 
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TASK 6: 
MACHINE THE END SLOTS WITH CURVE 5 AXIS 
 The two slots at the ends of the part will be machined next. Machining will be done with a 

flat endmill. This tool must be kept ‘normal’ to the floor surface of the slot. The 5 Axis Curve 
Toolpath will be used.  

 
 
1. Set Level 1 as the only visible level. 

 
 
2. Select the Curve Toolpath from the Multiaxis toolpath gallery. 

 
 
3. Select the 1/4 Flat Endmill from the tool list. 
4. Reduce the feedrate to 40 ipm. This path will be cutting a full slot so reducing the feedrate is 

necessary. 
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5. On the Cut Pattern page, set the Radial offset to 0.125 (half the diameter of the selected 
tool), Curve Type will be set to 3D Curves and then click the Selection button. 

 
 
6. The Chaining Manager should be in the Solid Mode. Enable only Edges selection. Select 

the edge shown. Direction is important. Reverse the chain if needed. Click Ok. 

 

 
 
7. On the Tool Axis Control page, set the Tool Axis Control to Surface. Then click on the 

selection button. 

 
  

Duane
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8. Select the face shown. This should be the same face the previous edge was selected from. 

  
 
9. Click End Selection. 
10. On the Linking page, set the Clearance to 8.0 and enable Only at the Start and End. 
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11. Expand the Linking settings and choose Entry/Exit. Enable both Entry and Exit Curve 
with a Length of 55%. This will provide a straight lead into and out of the cut that is slightly 
larger than the radius of the tool (this will clear the material). 

 
 
12. Enable Safety Zone. With the depth cuts being used, controlling where the retract and 

repositioning moves occur is suggested. Click the Defined Shape button and then select 
the part. Make the settings shown, Spherical with a Radius of 1.50 Click Ok. 
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13.   On the Roughing page enable 
Depth Cuts and set the # Rough 
Cuts to 4 and the Rough Step to 
0.05. 
 
Knowing the slot is 0.20 deep, 
setting 4 cuts of 0.05 each result in 
4 even depth cuts starting from the 
top of stock.  
 
If stepovers were needed in 
addition to depth cuts, Multi 
Passes can be enabled.  
 
This scenario, the endmill is the 
same width as the slot so no Multi 
Passes are needed. 

 
 
14. Click Ok to complete the toolpath. 
 The completed toolpath. (Wireframe view, fixtures hidden, toolpaths black only for clarity) 

Notice the depth cuts and the arcing retract movements. 
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15. Copy and Paste the Curve 5 Axis toolpath. This will duplicate the toolpath just made. We will 
adjust this copied path to do the slot on the opposite side of the part. 

 
 
16. Open the copied operation by click on its Parameter Folder. 
17. On the Cut Pattern page, clear the current selection, then click the selection button to 

choose a new 3D curve for the toolpath. 

 
 

18. Select the curve at the other end of the part. Click Ok. 
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19. On the Tool Axis Control page, clear the current selection, then click the selection button to 
choose a new surface. 

 
 
20. Select the face shown. It should be the same face the edge selection was done from. 

 
 
21. Click End Selection. 
22. Click Ok to complete the toolpath edits. Regenerate the operation. 
 The completed toolpaths. 
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TASK 7: 
MACHINE THE MIDDLE SLOT 
 The middle slot of the part will use the same toolpath as the previous slots, but a slightly 

different strategy will have to be used due to the machine’s rotation limits in the B axis. 
 The slot will be cut in two 90-degree increments, basically halfway each time starting from 

the outside. 
 Chaining this type of motion will require an additional step. Two pieces of wireframe 

geometry have been created on level 6 for this toolpath. For instructions on how to make 
this geometry, see the Tips and Techniques section. 

 
1. On the Levels Manager, turn on the visibility of level 6. 

 
 
2. Select the Curve Toolpath from the Multiaxis toolpath gallery. 

 
 
 Selection of a toolpath that was already made in the file will populate the values with those 

used in the previous instance, except for any geometry selections. 
3. The same tool will be used, 1/4 Flat Endmill, with the Feedrate reduced to 40 ipm. 
4. The Cut Pattern page will use some different settings. Set the Radial Offset value to 0. 

Then click the Curve Selection button. 
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5. Switch to the Wireframe Selection Mode with the Single selection method. Select one of 
the arc segments. Click Ok. 

 
 
6. The Tool Axis Control will be left to Surface. Click the selection button and select the face 

under the previously selected wireframe arc. Click End. 
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7. The remaining settings will be populated from the settings used in the previous Curve 
Toolpath. No further changes are needed. Click Ok to complete the toolpath. 

 The completed toolpath. Notice it only cuts half of the slot.  

 
 
8. Copy and Paste the Curve toolpath just made. This will keep all settings and all selected 

geometry. By copying the toolpath, we save having to reselect the under lying face for the 
tool axis control. We only need to select new Curve geometry. 

 
 
9. On the new toolpaths Cut Pattern page, clear the selected curve and then click the 

selection button to choose a new curve. 
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10. Ensure you are still in the Wireframe Mode and in the Single selectin method, choose the 
other half of the arc. 

 
 
11. Click Ok to complete the toolpath. 
12. Regenerate the toolpath. 
 The two completed toolpaths. 
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TASK 8: 
DEBURR THE PART 
 The final toolpath for this part will break the sharp corners and edges, it will deburr the part. 
 The Multi Axis Deburr toolpath in Mastercam makes complex 5 axis deburring very simple.  
 
1. From the Multi Axis toolpath gallery, select Deburr. 

 
 
2. Select the 3/16 Ball Endmill and update the toolpath comment. 

 
 
3. On the Cut Pattern page, click the Part Surfaces selection icon. Select the entire part 

model. 
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4. Set the Edge definition to User Defined and then click on the edge selection button. 

 
 
5. In Solid Edge selection mode, select the 6 edges of the 3 slots. Click Ok. 

 
 
6. The remaining settings on the Cut Pattern page will be left at the default values. 
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7. Tool Axis Control. Make the settings as shown. 

 
 
 The Machining Strategy is set to 5 axis, this will allows the machine to move any of its 

axes to reach the needed cutting area. With this, the Strategy is set to Normal to Contour. 
The toolpath will try and keep the tool normal (perpendicular) to the cutting edge. However, 
since we have features on all sides of the part, this Normal cutting strategy will lead to some 
extreme rotations which could lead to problems. To solve this, we have enabled limits on the 
tilting range of the toolpath.  

 
8. Linking, Type set to Sphere, Position and Radius set to Automatic. Click Ok to complete 

the toolpath. 
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 The completed toolpath. (fixtures hidden, toolpaths black only for clarity) 
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TASK 9: 
SETUP THE VERIFY AND SIMULATE OPTIONS  
 Before launching either Verify or Simulate, we need to setup some information in the 

options to get useful, accurate verification and simulations. 
 Verify = part cutting. Simulate = part cutting and machine motion. 
 
1. Click the Simulator Options button on the Toolpaths Manager. 

 
 
2. On the Components tab, turn Fixtures on and check level 100. Anything on level 100 will 

be simulated as a fixture. 
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3. No changes will be made on the Data tab. 
 If you have the UMC750 mach sim files you can use a VMC with a Trunnion. 
 
4. On the Simulation tab, select the camInstructor_HAAS UMC750. Set the Position to 

Translation in XYZ. Then click the button to the right to calculate the translation values. 

 
 
 
 If you do not have the camInstructor_HAAS UMC750 Mach Sim files, make the following 

settings instead. 
5. Select the 5_5AXGEN_VMCTTAB machine, Position set to Automatic. Click Ok.  
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TASK 10: 
VERIFY AND SIMULATE THE PART 
 
1. With all the toolpaths selected, click Verify. 

 
 
2. On the Home tab, activate the Stop Condition for Collisions.  

 
 
3. On the Verify tab, we’ve enabled Color Loop and Show Edges. 
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4. Click on File>Options and then on the General menu, enable Collision Checking with the 
Tool to the Fixture. Click Ok. 

 
 
5. Play through the verification. Your part should remain in place while the tool rotated to the 

different cutting planes. The Verification should go quick. You should also see your defined 
fixtures on screen. 
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 The verification did not detect any collisions. Switch to Simulate 
6. On the Home tab, select Simulation. 

 
 
7. The Machine Housing looks nice, but it will be in the way during Simulation. Hide it by 

completely unchecking the Machine Housing check box. 

 
 
8. The Simulation will accurately show all machine movement as the actual machine will make 

during the machining process. This Simulation will take longer than the Verification did.  
9. You can speed up or slow down the process by adjusting the Performance/Precision slider 

and/or the Slow/Fast slider.  
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 The completed Machine Simulation. 
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Five-Axis-Lesson-8-Ex1 
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Five-Axis-Lesson-8-Ex2 

 


